We're implementing additional security measures
Incident Report for Finch
Resolved
We're pleased to share that all app features are working again. If you still see the "under maintenance" message when you log into your Finch app, please update your app to the latest version in the AppStore (1.0.6).

Our team made a range of updates to secure our platform further. Below is a summary of what we changed and how this impacts your Finch account:

1. Revised deposit holds: Once you deposit into your Finch account, it takes us 5 days to invest your money and reflect it in your available balance. Your deposit will be listed as "pending" in your transaction feed, and you won't be able to spend this money during this time.
2. Adjusted debit card deposit limits: You can deposit up to $500 per day and $2,000 per month using a debit card.
3. Adjusted ACH transfers limits: You can transfer out up to $500 per day via ACH.
4. Adjusted external funding methods: You won't be able to use your Finch debit card to fund external accounts like Cash App and Apple Cash, but you can still transfer money out via ACH.
5. Modified the way to report problems within the app: If you experience any problems within the app or have any feedback for us, simply shake your phone to let us know.
Posted Jan 13, 2021 - 10:35 EST
Monitoring
We’re pleased to share that, with the exception of ACH transfers out, all app features are working again.

We sincerely apologize for the prolonged maintenance and limited functionality you have experienced on your Finch app. We are working hard to complete our maintenance procedures and will let you know when ACH transfers out are functional.

We appreciate your continued support and patience. If you need any support, please reach out to us at support@finchmoney.com
Posted Jan 09, 2021 - 15:23 EST
Update
We are continuing to work on these updates.
Posted Jan 08, 2021 - 14:03 EST
Identified
We limited some of the account features so we can implement additional security measures to protect your money.

As a result, you may notice a pop-up advising that we're down for a maintenance when you initiate a bank transfer, attempt a deposit, or try to activate a new card. We know that this is unacceptable, and we’re committed to fixing this issue ASAP. We appreciate your patience.

This should be resolved by January 10th, 2021.
Posted Jan 05, 2021 - 12:51 EST
This incident affected: 📱Finch App, 💳Card Payments, and 💸ACH Withdrawals.