We're aware of some issues with outgoing ACH transactions.
Incident Report for Finch
Resolved
We've now resolved the issue affecting ACH withdrawals. Please let us know if you experience any issues!
Posted Feb 03, 2021 - 09:21 EST
Monitoring
We are continuing to work on a fix for this issue. We expect the outgoing transfers to work properly on Monday. Please reach out to us at support@finchmoney.com if you need any help in the meantime.
Posted Jan 20, 2021 - 11:13 EST
Identified
We've identified two separate issues affecting ACH transactions not reflecting properly in your feed which we are fixing now. We'll have more updates on this by Wednesday. Please reach out to us at support@finchmoney.com if you need help.
Posted Jan 18, 2021 - 10:44 EST
Investigating
If you have attempted to transfer money out of your Finch account, you'll see the transaction in your feed but it won't reflect in your Available Balance. We are currently investigating this issue. Please reach out to us at support@finchmoney.com if you need help.
Posted Jan 15, 2021 - 11:59 EST
This incident affected: 💸ACH Withdrawals.