You won't be able to link Bank of America account to your Finch account until June 23rd
Incident Report for Finch
Resolved
This incident has been resolved.
Posted Jul 17, 2021 - 09:15 EDT
Identified
We've identified the issue which causes partial disruption to our account linking process. It affects only linking Bank of America accounts with a Finch account. It is scheduled to be fixed on June 23rd.
Posted Jun 02, 2021 - 01:55 EDT
This incident affected: 📱Finch App.