We're investigating an issue with logging into the app.
Incident Report for Finch
Resolved
This incident has been resolved.
Posted Dec 06, 2021 - 15:16 EST
Investigating
You may be experiencing issues with logging into your Finch app. We're investigating this issue.
Posted Dec 06, 2021 - 11:59 EST
This incident affected: 📱Finch App.