We're aware of some issues with outgoing ACH transactions.
Incident Report for Finch
Resolved
This incident has been resolved.
Posted Mar 17, 2021 - 13:14 EDT
Investigating
We are currently investigating this issue.
Posted Mar 10, 2021 - 15:42 EST
This incident affected: 💰ACH Deposits.